UI button not showing on iOS device


#1

Hi there,

I have a problem with my scene following the tutorial of using Aryzon + Vuforia for iOS (the tutorial I followed from the website: How to Build a 3D Augmented Reality Game w/ VUFORIA | Unity & Aryzon | AR Developers Tutorial Ep 3)

When I build the scene to my iPhoneSE everything works except for the UI button saying: Start Aryzon mode. This button is not showing at all. This way I can’t enter the stereoscopic mode to use the AR glasses. Does anyone have any idea what the problem could be and why it is not showing up? I’m new to Unity so figuring out the problem is pretty hard.

Thanks in advance!


#2

Have you manually added the button to the scene as shown in the tutorial? Do you see the button when in Unity Play mode? Can it have something to do with your aspect ratio and the button being shown outside of the screen bounds? In that case try placing it in the center of your screen.


#3

Hi Maarten, thanks a lot for your answer! Everything you mentioned I double checked and are fine. I tried making my project from scratch and that seemed to do the trick. No idea why it works now and not before, but it works! Maybe a bug or something.

So I have entered stereoscopic mode, and calibrated my iPhoneSE with the Aryzon glasses. The picture it projects is clear and sharp, really nice! But unfortunately it is either too small or not entirely in position. Any ideas on how to make the projection bigger and better positioned? Or is it because the phone screen is too small? Thanks again for your help :slight_smile:


#4

I’m glad you got it working :slight_smile: have you been able to enter the calibration code in your own app as well?

Make sure to enter the scene units correctly, otherwise you object might appear too far out or too close. I would suggest using meters as your scene units, you can set this on the Aryzon GameObject. You can then make your object ‘x’ meters large.

For instance, if you are using Vuforia and a marker image, then your marker image should reflect the size in the real world in meters as well. So if your marker is 20x20 cm, you should enter a scale of 0.2 in Unity. Hope this helps.


#5

Yes, I have looked at the units and there is no problem there. The problem lies more with the calibration process. I just can’t get the marker projection the same size as the physical marker object, whatever the distance is of the marker projection in relation to the physical marker is. I have added a sketch of my projection to show you what I mean.

When I try it with an android device (Xiaomi device) with a larger screen, the projection is much better. Any ideas on how to make it work on a smaller sized iPhone SE? Thanks again :slight_smile:


#6

I see, that’s a problem. The SDK grabs this information from an online database. I checked and we grouped the SE amongst the iPhone 6s category instead of the iPhone 5s. The 6s has a larger screen and would cause an incorrect FOV. Can you try again? If nothing has changed you might need to reinstall the app(s).

Thanks for bringing this to our attention and please let me know if the issue is fixed :slight_smile:


#7

Yes, that fixed a large part of the problem! It is a lot better than it used to be. Glad I could assist :slight_smile: Still there is a small problem with the size of the projection. Even though the projection is bigger now, it still doesn’t reach the edges of the physical marker. Here another sketch to show you what I mean:

Is this still fixable? Or is this the best it can do at the moment? I reinstalled the app and calibrated multiple times, but I can’t get it perfect. Sorry for my need to get it perfect, but my designed scene requires really precise measurements. Hope you can help.


#8

Is it the same now on both phones? Or is the SE still different? I suspect it is not a size difference, but a shift in the stereoscopic image, causing the image to appear too far out. Try closing one eye, there is always a point where the image matches. For your own headset you can tweak other settings, in this case I think it is the lensCenterDistance setting you should change. Try tweaking the AryzonSettings.Headset.lensCenterDistance setting by a very small amount at a time (0.001) and see if it helps. Beware, every headset is slightly different and therefore may project a little bit different than another headset. We have left this out as a calibration factor for now so another user with another headset might see a slightly different image. Therefore I would suggest leaving the setting at its default when you are publishing the app for other Aryzon headset owners.