Gradle errors using Aryzon with Firebase

Hello, I’m having issues with Gradle errors when running Aryzon on Android in combination with Firebase.
I’ve set up a blank project in Unity 2021.2.0f1 for the sole purpose of getting these 2 to work together.

I think that the following line in the mainTemplate.gradle keeps causing the issue.

implementation 'com.google.android.gms:play-services-vision:15.0.2'

I can comment it out, replace the version number with 17.0.2 or 20.1.3, and it will build, but I won’t be able to enter Aryzon mode on my Android device.

Gradle Error Paste: