ARCore support for Aryzon in Unity


#1

For AR Core integration follow these steps

On Android
Download AR services package and install on your android device (supported devices include: Nexus, Nexus 2 & Samsung S8)
https://github.com/google-ar/arcore-android-sdk/releases/download/sdk-preview/arcore-preview.apk
If you do not own one of the “required” android phones, download this modded AR services package:
https://github.com/tomthecarrot/arcore-for-all/raw/service-mod/service-mod/arcore-preview-modified.apk
Note: the tracking won’t be as smooth on these devices, see this as strictly testing devices. Also, still not every device will be supported with this package, test it out for yourself.
Go to: https://developers.google.com/ar/develop/unity/getting-started if you get stuck somewhere.

In Unity
In Unity 2017.2 or higher, create a new project and download and import the arcore example project, you can download it here: https://github.com/google-ar/arcore-unity-sdk/releases/download/sdk-preview/arcore-unity-sdk-preview.unitypackage
In your player settings, go to XR settings and turn on “ARCore supported”. In other settings turn off multithreaded rendering and set minimum api level to android 7.0 or higher.

Aryzon
Download and import the Aryzon unity package and open the ARCore example scene called: “HelloAR”.

Replace the ARCoreDevice/firstpersoncamera with the Aryzon prefab and set references of:

ARCoreDevice/sessioncomponent.cs/firstpersoncamera
to -> ARCoreDevice/Aryzon/ARCamera

and

ExampleController/helloARController.cs/firstpersoncamera
to -> ARCoreDevice/Aryzon/ARCamera/Cameras/Camera_Right

Delete the vuforia folder and slash out #define USE_VUFORIA in ARMode.cs to disable Vuforia functionality.

Disable the Aryzon/ARCamera/ARGyroCamera script to get correct tracking.

If you’re building to an unsupported android device, go to: googleARCore->SDK->plugins in your project window and replace unitygar.aar with this file: https://github.com/tomthecarrot/arcore-for-all/raw/master/unitygar.aar
Build the project to your phone and run it. You can place objects to the pointer location by pressing the right side of the screen.

Still having problems? post them below and we’ll be happy to help out!


#2

#3

he maarten,
I just tried to implement your SDK with the new 1.0 ARcore SDK

I think that with the recent release of the ARcore SDK some things has changed. for example in the HelloAR scene I try to find ‘ARCoreDevice/sessioncomponent.cs/firstpersoncamera’ in order to replace it with your ARCamera but this ARCoreDevice is not in the HelloAR scene anymore.

Could this been changed with the 1.0 release?

Can you please update your documentation so we can implement this?
hope to hear
gr markv