Android newly unable to calibrate or recognize target


Last October, I received my viewer, and was able to get it calibrated and play with the sample apps (Android, Nexus 6P, 8.1).

I didn’t have time to really use it for a couple of months, but when I pulled it out today to try using it, it looks like a recent update (sometime between November 2018 and today… I have Google Play set to auto-update installed apps) is now causing it to be unable to recognize the target. So far, I’ve tried the following:

  • Uninstalled and reinstalled the “Aryzon” app from Google Play

  • Attempted to recalibrate it. It recognizes the QR code without any problems, but when I insert the phone into the viewer after affirming the disclaimer, it just doesn’t see the target.

I glanced over the logcat output while running the calibration app, but didn’t see anything that looked like an obvious error (though obviously, it’s kind of like searching for a needle in a haystack, and I could have easily overlooked it).

I’m pretty confident that it’s NOT due to a new problem with Android itself… it’s been almost a year since the last time I reflashed the phone.

An easy place to start would probably be for me to just try re-installing the old .apk that you published to Google Play prior to October 2018 to see whether the problem goes away, just because we know THAT version definitely worked & would be an easy way to eliminate phone-related problems as a likely reason.

Assuming you built the current (January 2019) release of the Aryzon app using the same .unitypackage that was released a few months ago (and not a newer private build that hasn’t been released yet), the next thing I’d be inclined to blame is Unity itself. Unity 2018.2 has had a LOT of nasty Android-specific bugs. :poop::scream::sob:

Hi Jeff, thanks for searching and suggesting possible causes. With the launch of the Aryzon Pop-up we have added a new (smaller) marker to the family. For simplicity reasons we created one image target to recognise both marker images (they overlap). This turns out not to be recognised properly on some phones. We are working on an update to fix the issue. It will hopefully be in the Play Store by the end of this week.

Ah, ok, that explains it.

Would downloading and printing the new, smaller marker help in the meantime? As far as I can tell, the link to download the printable marker on the FAQ page still points to the old, large marker.

The app has been updated, the new version (31088) should be visible in the Play Store soon. Hope it works now!

The small marker is an addition to the large marker, not a replacement :slight_smile:

I just tried to calibrate using the newly-updated version… Unfortunately, it’s still not working. I get to the screen that says, “Hold the physical marker up, in view of your phone’s camera”, but it doesn’t seem to be detecting the marker.

Does the fish experience work for you in AR? This does not require a marker. Just curious to see if the camera feed itself is actually coming through or the app does not have the required permissions. You might need to start AR twice, the first time it will guide you through a tutorial.

I have the same problems.

The fish experience is working.
My Honor 10 doesn’t recognize the marker.

My Nexus 5X does, but has the problem that the augmentation is upside down.

I have the same issue on my Samsung A8 and on two other Android phones. Also I tested the app on an Iphone and there the calibrating is working normal.